MPLAB Tutorial

1. First download both MPLAB and C18 and install them into the default directories
(see www.microdigitaled.com for instructions).

2. After you have finished the above step, open MPLAB.
I

File Edit “iew Project Debugger Programmer Tools Configure  Window  Help

|DEE|smE [ SHAw D

e

Build | Version Control - Find in Files I

[ [ |PIC18F458 [ [0 Inovzdec [ |bankn |

Go to Menu->Project->Project Wizard.
~lolx]

File Edit Wiew | Project Debugger Programmer Toolks Configure  Window Help

Mew. ..
Open...

Close >
Set Active Project »

Quickbuild (no . asm File)

Cleamn
Build Optians. .. 3

Save Projech

Save Projech &5...

Add Files o Praject, ..

Add Mew File ta Project.. .
Remave File From Project »

Select Language Toolsuite, ..
Set Language Tool Locations...
Wersion Contraol...

[ [
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MPLAB Tutorial

Hit Next to bypass the Welcome screen and select the PIC processor for the project and hit Next.

=Ll x|
Hroecrwzars

T Step One:
4L Select a device /"
r &

Device:

< Back I Mext > I

Cancel | Help

[PIC1&F455 [0 lnovzdec [ |banko |

Select the Microchip C18 Toolsuite and hit Next (This assumes C18 was installed previously).
MPLAR TD ;lilﬂ

rr—— ﬂ—

] Step Two: EE‘

J—

Select a language toolsuite
Active Toolsuits: Microchip C18 Toolsuite j
B Knudsen Data CCE<
r— Toolsuits Contents | B Krudsen Data CCEE
Byte Craft Azzembler & C Compiler
CCS C Compiler for PIC1 241416418

MPLINK Dblect 4R Fict
MPLAB C18C [ f
WP IR | roiarpe sagstems Midrange

Mic C18 Toolsuite
Microchip MPASH Toolsuite

i~ Location

C:\Program FileshMicrochiphMPASM Suite\MPAsmiwin exe Brovise. |

Help! My Suite lsn't Listed! | [~ Show all installed toolsuites

< Back I Mext > I

Cancel | Help

[
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MPLAB Tutorial

Give the project a name and directory and hit Next.

===

MELAB 1D
S Project Wizard

J Step Three:

Mame pour project

i Project Hame
IM yProject]

— Project Director

Ic:\temp\MyPrDiacnl Browse... |

< Back I Mext » I

Cancel | Help

[PIC15Fass [w:o lnevzdee [ |barko |

Hit OK to create directory, if needed.
X

Step Three: N
Mame your project EE/{#@}

Project Wizard 3 =l

\‘.p The directory “c:itempiMyProject 1} does not exist. Would you like to create it?

Coen

< Back MNext > | Cancel I Help

| [PIciaFass [ lnovedee | [barka |
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MPLAB Tutorial

Find the C18 Ikr directory, usually C:\MCC18\Ikr\18f458i.lkr, Hit Add>> and check box.

S Project Wizard
b
] 18R510.Ikr

180580 kr | C:5MCCT 84k 1 BF45E
bl rovésti el ’
1 18510 e lkr
18H5{1 i ke Remove
18R510_e.lki —I

184610.lkr

184E10_e.lkr

] 18R4T 0ilkr

184610i_e.lkr

184620 Ik 4] | |
18[4820._8"“ Check the box to copy the file to the

18f4820"|k[_lll project directory. Click the filename to

b edit the name of the local copy.

J Step Four:
1 Add any exizting files to your project
=
-

< Back I Mext > I

Cancel | Help

[PIc15F4ss 7] novadoc [ |banko |

Hit Next and then hit Finish.

Click Finizh' to create the project with these parameters.

Project P.
Device:  PICT18F458

Toolsuite:  Micrachip C18 Toolsuite

File: c:htlemphhpPioject] \MyProjectl. mcp

A new workspace will be created, and the new project added
to that workspace.

< Back I Finish I Cancel I Help

[PIC18F455 [0 lnovzdec [ |banko |
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MPLAB Tutorial

Go to Menu->Project->Add New File to Project.
=lex|

File Edit Wiew | Project Debugger Programmer Tools Configure ‘Window Help

J 0E | | Project Wizard. .. |B o o | & |

Close 3

3 MyPro
8 i Set Active Project »
D Sou

(23 Hee  Guickbuild (ma , asm Fle)

g C_'b] Clean
T Ctrl+F10
Ok e F10
e Build ©ptions. .. 3
23 otk

Save Project
Save Project As...

Add Files to Project. ..

Remave File From Project

Select Language Toolsuite. ..
Set Language Tool Locations.. .

Wersion Control...

w0 [ [bank [ —r—

Browse and find your project directory.

To use MPLAB for an Assembly program, save a file with the .asm extension. MPLAB will open the file.
=151

Fil= Edit Vew Project Debugger Programmer Tools Corfigure ‘Window Help
D ima(sawe|cegnolc | R

2./ e ol

Save in I&)MPF’ID\EDH j Qe

[PIc15F4ss novadoc

- Microchip Technology */ j
=) 15F4sgi ke ol My Project 1 mow
main. asm MyPrn]ectl.mptags Fode, including initialized data *7
El main, err MyProiectl.tagsrc
=1 main.lsk to the user's main routine *f
=] main.o s

Frartup function *7

@ MyPraojectl.cad

MyProject1.cof

@ MyFroject.hex initialized data setup */

@ MyProject1.lst 3

=] myProject1.map
MyProjectl.mop

File name: Imain_d - I
Save as lppe: IAI\ Files [*."] j Cancel Fra=0z000000

v

hnsigned long short TELPTE:
Fano;
BoS,

—EMCEY [roIar

{
_asm goto _startup _endasm

]

gpragma code _startup_scn

|MPLAB SIM [PIC18F45E w0 novzdoc [ |banko |
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MPLAB Tutorial

Now you can type your Assembly code or insert the Assembly code into the file.
ETFY

File Edit %iew Project Debugger Programmer Tools Configure  ‘Window  Help

|Dza| i we a0 ?|| cs@BO | S@

= ] MyProject Lmep main asm* | 181458k |
1-[Z0 Source Files 1 #include =<plEf458 incs [—
E main. asm ra GLOBAL main ;define main as global so linker can find it =
(22 Header Files 3 ORE OxZd ;lock din lkr file for start of page
-.[Z2 Object Files 4 main: ;main will siuple toggle PORTE and PORTD
} ) & CLRF TLIZE jolear tristate register to make PORTE outcput
[ Library Files & CLRE TRISD ;jolear tristate register to make DORTD output
=-[20 Linker Scripts 7 MOVLW 0x55 ;load WREG with initial walue
E E 16F458i. ke il MOVWF PORTE smove walue in WREG to PORTE
[ other Files o MDVWE FORTD  smowe walue in WREG to PORTD
10 BACH: ;the program will not escape this loop
11 COMF PORTE,F,i;complement PORTE in Access bank and return to File register
12 COMEF PORTD,F,A;complement PORTD in Access bank and return to File register
13 BRR ELCE ;branch to beginning of loop
_-— 14 END stell the assembler that we are finished with this file
D Files

[PIC18F455 [0 lnovzdec [ |bank o [Ln 14, Cal 72 NS [WR

The ORG value is already set by the linker, however, if you want to compile the program for a different

PIC.processor you must copy and insert the new value for ORG which is found in the .Ikr file.
IETEY

File Edit %iew Project Debugger Programmer Tools Configure  ‘Window  Help

|Dze | s ea anw?|| cs@Bo | &@
L =0 | o

= [ MyProjectL.mcp main.zsm® 180458k |
=123 Source Files

main. asm
(20 Header Files
(20 Cbject Files
(B Library Files FILES c0l8i.o

=23 Linker Seripts FILEE clib.lib

(= 1@ a5 ke il FILES plEf4ss.lib

-[Z0 cther Files 10
11 CODEPAGE

44 File: 18£4584i 1kr
44 Sample ICDZ linker script for the PIC18F458 processor

Ll

ra
3
4
& LIEPATH C:3ZMCCLl33%1lib
&
-
2

START=0x0 END=0x23 PROTECTED
E EF
ebugy ETART=0x7DCO END=0x7FFF

12 CODEPAGE AN, PROTECTED
14 CODEPAGE NAME=idlocs START=0xZ00000 END=0xZ00007 PROTECTED
15 CODEPAGE NAME=config ETART=0x200000 END=0:x200000 PROTECTED
[1e CODEPAGE ETART=0x2FFFFE END=0x2FFFFF PROTECTEL

CODEPAGE NANE=cedata START=0xFOOO0O END=0xFOOOFF PROTECTEL

ACCESSBANKE MAME=accessram START=0x0 END=0x5F

20 DATABANE NAME=gprO START=0x&0 END=0xFF

21 DATABANE NAME=gprl START=0x100 END=0x1FF

2z DATABANE NAME=gprZ START=0xZ00 END=0xZIFF

22 DATABANK NAME=gpr2 ETART=0x200 END=0x2FF

24 DATABANK NAME=gpr4 ETART=0x400 END=0x4FF

25 DATABANK NANE=gprS START=0x500 END=0x5F3

s DATABANKE MNAME=dhospr START=0x5F4 EMD=0x5FF PROTECTED _l_l

3

[PIC18F455 [0 lnovzdec [ |bank o [Ln 13, Cal 1
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MPLAB Tutorial

Click the Build Toolbar button to compile.
IR

File Edit %iew Project Debugger Programmer Tools Configure  ‘Window  Help
|ozd|ima2awe ocs@Bo|Se
(. =l0) ]

Build | Yersion Control | Find in Files |

Executing: "ChiProgram Files\MicrochiphWMPASM SuiteyMPAsmWin.exe" /o /pl1 GF458 "main.asm" /"main.lst" fe"main.en” fo"main.o" ;l
Executing: "CMACCT Sibinmplink.exe" A"CAMCCT8Yib" "CATempityProjectih 184581 ke "CATempitMyProjectlymain.o" /o"MyProject] .cof" /M"MyProjectl .map"

HPLINK 4.00, Linker

Copyright (c) 2005 MHicrochip Technology Inc

Errors o0

MP2C0D 4.00. COFF to COD File Converter
Copyright {(c) 2005 Hicrochip Technology Inc.
Errors o0

HPZ2HEX 4.00, COFF to HEX File Converter
Copyright (c) 2005 Hicrochip Technology Inc.
Errors o0

Loaded CATempihyProjectliWyProject! cof
BUILD SUCCEEDED: Sun Jan 21 19:01:49 2007

[PIC18F455 [0 lnovzdec [ |banko | R

To simulate your program go to Menu->Debug->Select Tool->3 MPLAB SIM.

Clear Memory ¥ 1 MPLAE ICD 2

2 MPLAEICE 4000
= D MyProjectl.mcp i 4 MPLAB ICE 2000
=23 Source Files 1 5 RICKE 2 458.incs =
H main, asm 2 T GLOBAL main  ;define main as global so linker can find it =
(23 Header Files ] ORG Ox2A ;look in lkr file for start of page
[0 Object Files 4 main: ;main will simple togyle PORTE and PORTD
- ) H CLRF TLISE jolear nristate register to make PORTE outpuc
(3 Library Files 3 CLERF TLISD ;jolear tristate register to make DORTD output
=120 Linker Seripts 7 MOVLW Ox55 ;load WREG with initial walus
H 18F458i Ik i MOWWF DPORTE  ;move walue in WREG to PORTE
.12 other Files ] MOVWE PORTD  ;move walue in WREG to PORTD
10 BACH: ;the program will not escape this loop
11 COMF PORTE,F, A;complement PORTE in Access bank and rewurn to File register
1z COMF PORTD,F,A;complement PORTD in Access bank and return to File register
13 BRA EACK shranch to beginning of loop
—-_ 14 END ;tell the assembler that we are finished with this file
Eijs

[ |bank 0 [Cn 14, Cal 72 NS [WR

[PIc18F45s [0 novzdec
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MPLAB Tutorial

To view the registers and variables Go to Menu->View->Watch.
IR

File Edit | View Project Debugger Programmer Tools Configure  ‘Window  Help

v Fraject J DA T A A A R E i
w Output
Toolbars L@' AB IDE Editor

1 Disassembly Listing 18f458\.|kr|
2 Hardware Stack #include =<plEf458 incs

[r]

3 Program Memory GLOBAL main ;define main as global so linker can find it

4 File Registers ORG OxZhA slook in lkr file for start of page

S EEPROM main: ;main will simple toggle PORTE =nd FORTD
CLRF TRIZE fclear tristate register to make PORTE oucpuc

[

6 Memory Usage Gauge
[
[

) CLRE TRISD jolear tristate register £o make PORTD output
- MOVLY 0x55 ;load UREG with initial walus
& Locals MOVWE PORTE  ;umowe walus in WRES to PORTE
MOWMF PORTD  mowe walue in WRES to PORTD
10l stack BACH: ;the program will not escape this loop
11 Spedial Function Registers COME PORTE,F,i;complement PORTE in Access bank and return to File register
COMF PORTD,F,&;couplement PORTD in Access bank and return to File register
Simulatar Trace BRRL EALCK sbranch to beginning of loop
Simulator Logic Anakyzer ENL stell the assembler that we are finished with this file

[Z] Files = Dol

[MPLAE SIM [PIC18F455 lpeio [0 lnovzdec [ |bank o [Ln 14, Cal 72 NS [WR

Select PORTB and PORTD and hit Add SFR.
=i®ix]

File Edit W%iew Project Debugger Programmer Tools Configure  Window  Help

|| 2B Sne?| | ocsBBO| s
=

= L1 MyProjectl.mcp main. asm | 1814581 1kr |

| oo B GE

- saurce Files n #include <plSf4E5.incs =
main, asm B GLOBAL main  ;define main as global so linker can find ic =
o [EfEje: in U file for start of page

in will simple toggle PORTE and PORTD
Add Symhnl”ADEDNDhlts vl ear tristate register to make PORTE output
ear tristate register to make PORTD output
ad WREG with initial walue

e walus in WREG to PORTE
e walus in WREG to PORTD
e program will not escape this loop
uplement PORTE in Access bamk and return to File register
wplement PORTD in Access bank and return to File register
anch o beginming of loop

11 the assembler that we are finished with this file

Do

(23 Litw

= Linl Addy
L

Dot

“thol Name I Hex |

| wiatch 1

D Files

[MPLAE SIM [PIc18F45E f novzdee [ |banko |
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MPLAB Tutorial

1. To single step click on the icon on the Debug Toolbar.

2. To set a breakpoint on Line 11 right-click on the line and select Set Breakpoint.
I

File Edit W%iew Project Debugger Programmer Tools Configure  Window  Help

| o= H|%hi|§ﬁm?] == | v mee ® O {7 B | «——Debug Toolbar

I i
5 ¥ _I MPLAB IDE Editor
= _J MyProjectl.mep main. ssm | 186458 1kr |
-0 Source Files 1 #include =plSf4E5.incs =
main, asm z GLOBAL main  ;define main as global so linker can find it =
.[E3 Header Files i ORG OxZA jlock im lkr file for start of page
[0 Obiect Files 4 main: smain will simple toggle PORTE and PORTD
0 ) 5 CLRF TRISE ;olear tristate register to make PORTE cutpuc
- Library Files & CLRF TRISD ;elear tristate register to make PORTD output
=] [:l Linker Scripts 7 MOVL® 0x55 ;load WREG with initial wvalue
E 1af458. ky = MOVWE FPOLRTE ;move walue in WREG to PORTE
{2 other Files = MOVWE PORTD  ;move walus in WREG to PORTD
10 BACE: jvhe program will not sscape this loop
11 COME PORTE, F, e ‘poess bank and return to File register
12 COME PORTD, F 3 Remay Fiier Trace CoN el ) et o LI e ey
13 BRR EACE Remave Al Filter Traces k loop
14 END Add Filtet-out Trace bt we are finished with this file
J 15 Add Filter-in Trace
16 —_— —
Close
Ereakpoints
Run ko Cursor
Set PC at Cursor
GoTo...
GoTo Locator
Cut

Faste

Add SFR IPDHTD ~] AddSy  peete

ALddress I S¥mbe  ndd To Project
OFS1 PORTE g ipvanced b
OFS3 PORTD Bookmarks L4
Code Folding L4
Text Mode L4

Properties...

[watch 1 watch2| watch3[ watch 4]

[ [banko [Ln 11, Cal 13 NS [WR

[MPLAE SIM [PIc15F4ss lpcio 7] novadoc

Hit the Run Toolbar button several times and observe the values changing in Watch.
ETFY

File Edit %iew Project Debugger Programmer Tools Configure  ‘Window  Help

| D= H|%hﬁ|§ﬁw’? ==

| e | vjmee® G

—I—I—I MPLAB IDE Editor
= (L] MyProjectl.mcp main.asm | 18f458 lkr |
=120 Source Files 1 #include =<plEfdE8 incH [—
main. asm = GLOBAL main  ;define main as global so linker can find it =
[23 Header Files i ORG OxZh ;loock in lkr file for start of page
[0 Object Files < nain: ;main will simple toggle PORTE and PORTD
- ) H CLEE TRISE ;olear tristate register to make PORTE outpuc
-+ Library Files & CLRE THISD ;jolear tristate register to make DORTD outputc
- Linker Seripts 7 MOVLW Ox55 ;load WREG with initial walue
L [2 1mfasa ke s MOVME FORTE  ;move walus in WREG to PORTE
[Z3 other Files o MOVWWF PORTD  ;mowe walue in WREG to PORTD
10 BLCH: ;the program will not escape this loop
11 @ | CoMF PORTE,F, A;complement ENRETB in hecess hank and return to File register
12 COME PORTD,F,A;complement PORTD in Access bank and return to File register
13 BRER EBACK ;branch to beginning of loop
_-_ 14 END ;uell the assembler that we are finished wich this file
iles

Add SFR IPDHTD ~| Add SymeII ADCOMObit: 'I

Address I Syvmbol Name I Hex |
OF&1 FPORTE 0xS5
OFa3 FPORTD 0x55

[Watch1 | Watch 2 [ watch 3] watch 4]

[MPLAE SIM [PIC18F455 [P w055 lnovzdce [ |bank o [Ln 11, Cal 1 NS [WR
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MPLAB Tutorial

To use MPLAB for a C program, right-click on the .asm file in the project and select Remove.
~18]x]

File Edit %iew Project Debugger Programmer Tools Configure  ‘Window  Help

|oeE|ima | 2aw?|cesmBo| S
B o B e s RETEY

= D MyProjectl.mcp maln. asmm 13f458\_|k,|

| v O

1-[Z0 Source Files |1 finclude <plEf458 incs —
M comile GLOBAL main  ;define main as global so linker can find it =
23 Head: Asseprnhle ORE OxZh ;lock in lkr file for start of page
.23 obiec nain: ;main will simple toggle PORTE and PORTD
2 b Build Options... CLEF TRISE jolear nriscate register o make PORTE outpuc
ol Libear  PRRR PR CLEF TRISD jolear tristate register to make PORTD output
E|[:| Linker  Egit MOVL® 0x55 ;load WREG with initial walus

HOVWF FORTE smowve walue in WREG to PORTE
MOVWF PORTD smove walue in WREG to PORTD

BACH: sthe program will not escape this loop
PO ] COMF PORTE,F,A;complenent PORTE in Access bank and return to File register
1z COMF FORTD,F, A;complement PORTD in Access bank and return to File register
13 BRA EACK jbranch to beginning of loop

14 END stell the assembler that we are finished with this file

Oc Symbols

D Files

el |

T -0l
Add SFR IPDHTD ~| Add SymeII ADCOMObit: 'I

ALddress I Symbol Name I Hex |
OF&1 FPORTE OxAh
OFs3 PORTD Oxihh

[Watch1  Watch2 [ watch 3] waich4]

[MPLAE SIM [PIC18F455 [Pz w0255 [ |banko |

Go to Menu->Project->Add New File to Project (see Page 5).

Browse zour : ro'lect directog and save a file with the .c extension. MPLAB will open the file.
+ MyProjectl - MPLAB IDE v7.41 = |

File Edit Wiew Project Debugger Programmer Tools  Configure  Swindow  Help
| Do H| s snw?| icEDO|Sn BT

21 R ol

Save in I@My?roiecﬂ j Q2

Movzdoc

Microchip Technology */ j
18F 4580, kr MyProjectl.mowe =
main, asm MyProjectl.mptags Fode, including initialized data */
E] main.err MyProjectl .tagsrc
2 main Ist to the user's main routine *J
(= main.o i

Frartup function *f

(€] MyPraject 1. cad

MyProjectl.cof

() nayPraject 1 hex hnitialized data setup */

=] MyProect1.lst -

|§1 MyProjectl.map
MyProjectl.mcp unsigned long short TELPTR:

FSEO:
S
File name: |main.of Save I
Save as type: [l Files () =1 Cancel | pmowooomeo

%

FICEY | UOXT

_asm goto _startup _

+

fpragma code _startup_scn

[MPLAE SIM [ |PIC18F458 |pc:o [w:0 lnovzdoc [ banko |
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MPLAB Tutorial

Now you can type your C18 code or insert the C18 code into the file.
JEIE

File Edit %iew Project Debugger Programmer Tools Configure  Window Help
D |ime a8w? | 0sEBBO Syl | v e &6
i ol

= D MyProjectl.mcp elilEs mam.c |
.23 source Files 1 #include <pl8fess k- . . . —
) H wvoid maini) | ffmain will simple toggle PORTE and PORTD =
LIETHS 2 TRISE - Ox00; ffelear tristate register to malke FORTE output
20 Header Files 4 TRISD = Ox00; ffclear tristate register to make PORTD output
- Objeck Files 5 PORTE = OxGE; #fload PORTE with initial wvalue
[ Library Files 3 PORTD = Ox55; ffload PORTD with initial walue
-3 Linker Seripts d while (1) { fithe program will not escape this loop
) il PORTE = ~PORTE; //complement PORTE
= 1af4zpilke il PORTD = ~PORTD; //complement PORTD
(22 Other Files 10 t f/branch to beginning of loop
11 }
1z |

|MPLAE ST [PIC18F452 |pcio w0 novzdoe [ |bank 0 |Ln 12, Cal1 S [wWR

Click the Build Toolbar button to compile the program.

% MyProject1 - MPLAB IDE v7.41 _18]x]
File Edit %iew Project Debugger Programmer Tools Configure  ‘Window  Help

|Dd|ima(anw?| ocs—LO0| S8 [ vwwnrem|

L CTT i
Buld |Vers|cm Cortrol| FindiinFies | main.asm | 186458 lkr | maine  cO18ic |
Executing: "CAMCC Byainymplint | #* Copyright (c)1999 Microchip Technology *J j ]
MPLINK 4 .00, Linker [+
Copyright (c) 2005 Hicrc||s #* MPLAB-C15 startup code, including initialized data */
Errors o & J
7 A% external reference to the user's main routine *f
MP2COD 4.00, COFF tD_COI i extern void main (woid);
%?Eg;;ght (':% 2005 Micre|ly 4% prototype for the startup functicm 7
10 woid _entry (veid);
HFZHEX 4.00. COFF to HE:|[L1 woid _starcup [void):
Copyright {c) 2005 Micrc||l2 #* prototype for the initialized data setup */
Errors ) 13 woid _do_cinit (woid) ;
14
Loaded CATempyMyProjectyh: | |; extern volatile near unsigned long short TELDPTE;
BUILD SUCCEEDED: Sun Jan 2| l1e extern near unsigned FERO;
177 extern near char FPFLAGE:
15 #define END ©
fpragua code _entry_scn=0x000000
woid
_encrey (woid)
{
_asm goto _startup _endasm
¥
#pragma code _startup_scn

Add SFR IADCDND ~| Add SymeII ADCOMObit: 'I

Address I Syvmbol Name I Hex |
OF&1 FPORTE OxAh
OFa3 FORTD Oxih

[Watch1 | Watch 2 [ watch 3] watch 4]

[MPLAE SIM [PIC18F455 w055 lnovzdec [ |bank o [Ln 24, ol 1 NS [WR
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MPLAB Tutorial

To simulate the program, set a breakpoint by right-clicking the line and selecting Set Breakpoint.
IR
File ditView Project Debugger Programmer Tools  Configure  Window  Help £

|Dd|ima(anw?| o sRBO|[SE
imjxjpd

main.asm | 186458k mainc | on1gic |
#include “plBf458 h=

[ vwwnrem|

Build | Yersion Conirol | Find in Files |

Executing: "CACCT Byhinymplink

[r]

1
MPLINK 4.00. Linker = wvoid maini) { f/main will simple toggle PORTE and PORTD
Copyright (C) 2005 Hicwe|lz TRISE = 0x00, ffelear tristate register to maks PORTE cutput
Errors 4 TRISD = 0x00; ffolear tristate register to make PORTD outpuc
s PORTE = OxEE; //load PORTE with initial value
gPZCOD ﬁ oo, nggstﬁ COL e PORTD = OxEE; //load PORTD with initial value
E?Eg;;g t (':) icrell, while il | ffthe program will not escape this loop
M Ll
HP2HEX 4 00. COFF to HE3|[® oo = ~sont IELIVE R
Copyright (c) 2005 Micrc|fio ¥ Femoz AllFliar Traces R
Errors 11 } Add Filker-out Trace
X 12 Add Filker-in Trace
Loaded CATempibyProjectyh: | |12
BUILD SUCCEEDED: Sun Jan 2 Clase

Ereakpoints 3 |

Run ko Cursor
Set PC ab Cursor

GaTo...
GoTo Locator

Cut
Copy
Faste
Delete

Add To Project

Add SFR IADCDND v| AddSen Advanced

ALddress I Symbol Bo:lkmarll;s.
OF51 FORTE Coda Folding
Text Mode

OF83 PORTD
Propertie:

[Watch1  Watch2 [ watch 3] waich4]

[MPLAE SIM [PIC18F455 lpeio w0255 lnovzdec [ |bank o [Ln &, Cal20 NS [WR

Press F2 and Remove the .asm breakpoint, which has a “?” next to it, hit OK.

W MyProject1 - MPLAB IDE v7.41 =0 |
File Edit W%iew Project Debugger Programmer Tools  Configure  Window  Help
|Deu | ime gnw? || =BBO | S [ v oo
- | MPLAB IDE Editor ] S =

Ewild i it Fi -

| Lersion Enntrnll find i FIIESI main. a3m I 18f4580 ke Maln.c | cl18ic I ]

Executing: "CAMCCT Sypintmpling | [ ERSTEERE RIS SR =

MPLINE 4. 00. Linker 2 woid main() | ffmain will simple toggle PORTE and PORTD =

Copyright (:) 2005 Hicre|[2 TRISE = 0Ox00; ffolear tristate register to maks PORTE output

Errors & TRISD = 0Ox00; ffclear tristate register to maks PORTD cutput

5 PORTE = 0Ox55; ##load PORTE with initial walue

MP2COD 4.00. COFF to COT|| PORTD = MwES - ffload DODTD mith initial sralie

Copyright (l:) 2005 Hicrc = hite

Errors

= 0 PORT

MP2HEX 4.00, COFF to HE3|[8 pory  Bieak at

Copyright (C) 2005 Hicrc|f1o } IE'\Temp\MyF’ln\ecﬂ\main asm, 11

Errors 11 }

. 12 .
Loaded ChTempiiyProjectlih |15 Program kMemory Break pairts:
BUILD SUCCEEDED: Sun Jan 2 &) Remove
Remove &)l

Enable All
Disable Al

Active Breakpoint Limit: Ayailable Breakpoints:

Urlimited IUnhmited

oK LCancel

Add SFR IADEDND > | Add Symhnll ADCOMObit: vl

ALddress I Symbol Name I Hex |
OFs1 FORTE Ox55
OF&3 FPORTD OxSS

[Wateh 1 watch2| watch 3] watch 4]
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MPLAB Tutorial

Hit the Run Toolbar button several times and observe the values changing in Watch.
=lex|

File Edit W%iew Project Debugger Programmer Tools Configure  Window  Help

|Dsu| ima | anwe||cs@Bo | o | ol @ o
R

maln.asml 18645811k main.c | =1 Bl.cl

Build | Wersion Control | Find in Files |

Executing: "CAMCCT Sybinkmpling | [ ERSTEERE OSSR e =
MPLINE 4. 00. Linker 2 woid maini) | ffmain will simple toggle PORTE and PORTD =
Copyright () 2005 Hicre|[? TRISE = 0Ox00; ffolear tristate register to maks PORTE output
Errors o0 4 TRISD = Ox00; ffclear tristate register to make PORTD ocutput
5 PORTE = 0Ox55; ##load PORTE with initial walue
MP2COD 4.00. COFF to COT|HS PORTD = 0Ox55; #fload PORTD with initial walue
ggggiéght ?C% 2005 Micre|l, while(l} { //the program will net escape this loop
= =] PORTE = ~PORTE; //complement PORTE
HPZHEX 4.00, COFF to HEI|[[|? PORTD = ~PORTD; //complement PORTD
Copyright (o) 2005 Micrc|[|l0 3 Sibranch to beginning of loop
Errors o0 11 3
12

Loaded CATempihMyProjectlihd | |12
BUILD SUCCEEDED: Sun Jan 2

Add SFR IADEDNU ~| Add Symbull ADCOMNObit: VI

Address I Symbol Name I Hex |
oFs1 PORTE Ox55
OF&3 FPORTD 0xS5S

[watch 1 watch2| watch3[ watch 4]
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